summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 10:00:44 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 10:00:44 +0000
commit219313833a7249112d9d604afc703e2ef7a6daac (patch)
tree9c46371885a514369092148370b7aaf7988ce17f
parent7852c48ffd448cec26aeaa0622d00644c3e2158f (diff)
downloadmaster-31e0f0ae-219313833a7249112d9d604afc703e2ef7a6daac.tar.gz
master-31e0f0ae-219313833a7249112d9d604afc703e2ef7a6daac.tar.bz2
master-31e0f0ae-219313833a7249112d9d604afc703e2ef7a6daac.zip
Add INA2XX current sensor module.
This is a I2C current/voltage/power sensor. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> SVN-Revision: 36182
-rw-r--r--package/kernel/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index bc1f65281d..969e8fa3aa 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -60,6 +60,21 @@ endef
$(eval $(call KernelPackage,hwmon-adt7475))
+define KernelPackage/hwmon-ina2xx
+ TITLE:=INA2XX monitoring support
+ KCONFIG:=CONFIG_SENSORS_INA2XX
+ FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
+ AUTOLOAD:=$(call AutoLoad,60,ina2xx)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ina2xx/description
+ Kernel module for ina2xx dc current monitor chips
+endef
+
+$(eval $(call KernelPackage,hwmon-ina2xx))
+
+
define KernelPackage/hwmon-lm63
TITLE:=LM63/64 monitoring support
KCONFIG:=CONFIG_SENSORS_LM63