summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 17:03:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 17:03:38 +0000
commit2122cf17170ced9745c8a1b57d336ce73000bd52 (patch)
tree76df07cd9392015f52c8afe8c405696081aa08ba
parent6d7097f89976fee9da23ef798d687e9b0d57f276 (diff)
downloadmaster-31e0f0ae-2122cf17170ced9745c8a1b57d336ce73000bd52.tar.gz
master-31e0f0ae-2122cf17170ced9745c8a1b57d336ce73000bd52.tar.bz2
master-31e0f0ae-2122cf17170ced9745c8a1b57d336ce73000bd52.zip
only use --wildcards for gnu tar
SVN-Revision: 5022
-rw-r--r--openwrt/include/host.mk4
-rw-r--r--openwrt/toolchain/kernel-headers/Makefile3
2 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/include/host.mk b/openwrt/include/host.mk
index b4580e2b7a..6458881472 100644
--- a/openwrt/include/host.mk
+++ b/openwrt/include/host.mk
@@ -22,3 +22,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-e 's/cris.*/cris/' \
-e 's/i[3-9]86/i386/'`" >> $@
echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+ if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+ echo "TAR_OPTIONS+=--wildcards" >> $@; \
+ fi
+
diff --git a/openwrt/toolchain/kernel-headers/Makefile b/openwrt/toolchain/kernel-headers/Makefile
index 7b5c06c781..3e2cd2ae86 100644
--- a/openwrt/toolchain/kernel-headers/Makefile
+++ b/openwrt/toolchain/kernel-headers/Makefile
@@ -29,9 +29,10 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/armeb/arm/' \
)
+
define Build/Prepare
mkdir -p $(TOOLCHAIN_BUILD_DIR)
- bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+ bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
linux-$(PKG_VERSION)/include \
linux-$(PKG_VERSION)/Makefile \
linux-$(PKG_VERSION)/Rules.make \