summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-10 16:07:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-10 16:07:27 +0000
commit1fa3e7a9418477a807b01c201fb26bf735b41fd7 (patch)
treebc01e6402a9a3d5a7570b777b945cd96893930bd
parent127c395a0eb99d4d84bdc87c205ed7fd63dd5336 (diff)
downloadmaster-31e0f0ae-1fa3e7a9418477a807b01c201fb26bf735b41fd7.tar.gz
master-31e0f0ae-1fa3e7a9418477a807b01c201fb26bf735b41fd7.tar.bz2
master-31e0f0ae-1fa3e7a9418477a807b01c201fb26bf735b41fd7.zip
ar71xx: do not throw compile errors if the nbg460n uboot is not selected
SVN-Revision: 24426
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4c96a88bcf..44c030e4e0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -373,7 +373,8 @@ define Image/Build/WNDR3700
-o $(call imgname,$(1),$(2))-factory.img
endef
-define Image/Build/ZyXEL
+ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
+ define Image/Build/ZyXEL
$(call PatchKernelLzma,$(2),$(3))
if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
@@ -394,7 +395,8 @@ define Image/Build/ZyXEL
-r $(call imgname,$(1),$(2))-sysupgrade.bin:0x10000 \
-o $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
-endef
+ endef
+endif
define Image/Build/WNDR3700/initramfs
$(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))