summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-08-13 19:35:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-08-13 19:35:29 +0000
commit1d05e688ab26888b5a685331ab93f9378d26cb34 (patch)
tree7fffba8dde0455b6722eb9b9ad49a29a394c065a
parent2a888f2e238c3b930cba4f2bf8e9726fb65a29fb (diff)
downloadmaster-31e0f0ae-1d05e688ab26888b5a685331ab93f9378d26cb34.tar.gz
master-31e0f0ae-1d05e688ab26888b5a685331ab93f9378d26cb34.tar.bz2
master-31e0f0ae-1d05e688ab26888b5a685331ab93f9378d26cb34.zip
Allow mac80211 drivers to work in master mode
SVN-Revision: 12299
-rw-r--r--package/mac80211/Makefile5
-rw-r--r--package/mac80211/patches/004-allow-ap-vlan-modes.patch25
2 files changed, 27 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index d58904ffcf..21db08157e 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -12,10 +12,9 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_RELEASE:=1
-PKG_VERSION:=$(if $(CONFIG_TARGET_brcm47xx),2008-05-26,2008-07-19)
+PKG_VERSION:=2008-08-06
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=$(if $(CONFIG_TARGET_brcm47xx),http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/05,http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/07)
-#PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE_URL:=http://www.orbit-lab.org/kernel/compat-wireless-2.6/2008/08/
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
diff --git a/package/mac80211/patches/004-allow-ap-vlan-modes.patch b/package/mac80211/patches/004-allow-ap-vlan-modes.patch
new file mode 100644
index 0000000000..a8080b20ea
--- /dev/null
+++ b/package/mac80211/patches/004-allow-ap-vlan-modes.patch
@@ -0,0 +1,25 @@
+Subject: mac80211: allow AP and VLAN modes
+
+This patch allows switching interfaces into AP/VLAN modes using
+cfg80211 (nl80211). Don't allow doing it with wext because then
+people will just attempt to do it manually (without hostapd) and
+complain that it doesn't work.
+
+Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
+---
+ net/mac80211/cfg.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- everything.orig/net/mac80211/cfg.c 2008-08-06 21:38:13.000000000 +0200
++++ everything/net/mac80211/cfg.c 2008-08-06 21:38:24.000000000 +0200
+@@ -33,6 +33,10 @@ nl80211_type_to_mac80211_type(enum nl802
+ case NL80211_IFTYPE_MESH_POINT:
+ return IEEE80211_IF_TYPE_MESH_POINT;
+ #endif
++ case NL80211_IFTYPE_AP:
++ return IEEE80211_IF_TYPE_AP;
++ case NL80211_IFTYPE_AP_VLAN:
++ return IEEE80211_IF_TYPE_VLAN;
+ case NL80211_IFTYPE_WDS:
+ return IEEE80211_IF_TYPE_WDS;
+ default: