summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-03-18 15:57:18 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-03-18 15:57:18 +0000
commit1b216aa20a194e32ef6ff6ff028f58de49f29b20 (patch)
tree72f0d9a6e503e748d7cd2e475c4fd85ae2eee410
parent20b562636356a3b1ebeb7d18483e501422f23da7 (diff)
downloadmaster-31e0f0ae-1b216aa20a194e32ef6ff6ff028f58de49f29b20.tar.gz
master-31e0f0ae-1b216aa20a194e32ef6ff6ff028f58de49f29b20.tar.bz2
master-31e0f0ae-1b216aa20a194e32ef6ff6ff028f58de49f29b20.zip
Add FEATURE ramdisk to be able to select the use of INITRAMFS for a sub-target
SVN-Revision: 14939
-rw-r--r--Config.in2
-rwxr-xr-xscripts/metadata.pl1
-rw-r--r--target/Config.in3
-rw-r--r--target/linux/ps3/petitboot/target.mk4
4 files changed, 7 insertions, 3 deletions
diff --git a/Config.in b/Config.in
index e412338921..4d75896d8d 100644
--- a/Config.in
+++ b/Config.in
@@ -15,7 +15,7 @@ source "target/Config.in"
menu "Target Images"
config TARGET_ROOTFS_INITRAMFS
bool "ramdisk"
- default n
+ default y if USES_INITRAMFS
depends LINUX_2_6
help
Embed the rootfs into the kernel (initramfs)
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 3d9d68a654..c341e65261 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -163,6 +163,7 @@ sub target_config_features(@) {
/tgz/ and $ret .= "\tselect USES_TGZ\n";
/cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n";
/fpu/ and $ret .= "\tselect HAS_FPU\n";
+ /ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n";
}
return $ret;
}
diff --git a/target/Config.in b/target/Config.in
index 31f7a50b39..6506312b37 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -29,6 +29,9 @@ config USB_SUPPORT
config BIG_ENDIAN
bool
+config USES_INITRAMFS
+ bool
+
config USES_SQUASHFS
bool
diff --git a/target/linux/ps3/petitboot/target.mk b/target/linux/ps3/petitboot/target.mk
index a3d84dde03..4b53f57b6b 100644
--- a/target/linux/ps3/petitboot/target.mk
+++ b/target/linux/ps3/petitboot/target.mk
@@ -1,7 +1,7 @@
BOARDNAME:=Petitboot
-FEATURES:=fpu
+FEATURES:=fpu ramdisk
-DEFAULT_PACKAGES+= dnsmasq
+DEFAULT_PACKAGES+= dnsmasq petitboot
define Target/Description
Build Petitboot bootloader