summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 05:58:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 05:58:32 +0000
commit18141628dc544407c2adce31009df511b42d6a2d (patch)
tree922e7c5bf0da39deec105f3ce0e2fe85f26cb511
parent4fc427e21109a86d0870021a0c344c0587f7bd3a (diff)
downloadmaster-31e0f0ae-18141628dc544407c2adce31009df511b42d6a2d.tar.gz
master-31e0f0ae-18141628dc544407c2adce31009df511b42d6a2d.tar.bz2
master-31e0f0ae-18141628dc544407c2adce31009df511b42d6a2d.zip
ar71xx: build intramfs images for the Ubiquiti XM boards
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38147
-rw-r--r--target/linux/ar71xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a0b6e6d629..e0103a223c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -497,6 +497,7 @@ define Image/Build/UBNT2
-o $(call factoryname,$(1),$(2))
endef
+Image/Build/UBNTXM/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(ubntxm_mtdlayout))
Image/Build/UBNTXM/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
Image/Build/UBNTXM=$(call Image/Build/UBNT2,$(1),$(2),$(ubntxm_mtdlayout),$(4),$(5),$(6),$(7))