summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-15 07:36:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-15 07:36:15 +0000
commit162b8e23a5b6ddc158bd382cbd8ae8b31cac9082 (patch)
tree4b2186899ad176f455af45b0b3feede02ab57ff4
parentf35c369710959b964e0d16d5c45dd497093df61e (diff)
downloadmaster-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.tar.gz
master-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.tar.bz2
master-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.zip
kernel: update linux 3.7 to 3.7.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35604
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/adm5120/Makefile2
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch2
-rw-r--r--target/linux/brcm63xx/Makefile2
-rw-r--r--target/linux/cns21xx/Makefile2
-rw-r--r--target/linux/generic/patches-3.7/630-packet_socket_type.patch6
-rw-r--r--target/linux/generic/patches-3.7/651-wireless_mesh_header.patch2
-rw-r--r--target/linux/generic/patches-3.7/721-phy_packets.patch4
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/mpc83xx/Makefile2
-rw-r--r--target/linux/mpc85xx/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/rb532/Makefile2
-rw-r--r--target/linux/x86/alix2/target.mk2
-rw-r--r--target/linux/x86/geos/target.mk2
19 files changed, 23 insertions, 23 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 58e911ae42..062bfb495e 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,8 +8,8 @@ endif
ifeq ($(LINUX_VERSION),3.6.11)
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
endif
-ifeq ($(LINUX_VERSION),3.7.7)
- LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
+ifeq ($(LINUX_VERSION),3.7.8)
+ LINUX_KERNEL_MD5SUM:=4bc40d18bf90f25d5463cfb9442876af
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index 74b90d448a..6074aeeb68 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:=
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 1227df163f..aeed946ce9 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
index e7e1712b7e..70e03ac9ed 100644
--- a/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
@@ -191,7 +191,7 @@
/*
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3842,13 +3842,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3847,13 +3847,14 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 206763d772..3a686feaa0 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM63xx
FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index 96d90f370b..6736364aec 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-3.7/630-packet_socket_type.patch b/target/linux/generic/patches-3.7/630-packet_socket_type.patch
index 27a46078e6..40200377c9 100644
--- a/target/linux/generic/patches-3.7/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.7/630-packet_socket_type.patch
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2511,6 +2513,7 @@ static int packet_create(struct net *net
+@@ -2513,6 +2515,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3111,6 +3114,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3113,6 +3116,16 @@ packet_setsockopt(struct socket *sock, i
return fanout_add(sk, val & 0xffff, val >> 16);
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3165,6 +3178,13 @@ static int packet_getsockopt(struct sock
+@@ -3167,6 +3180,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-3.7/651-wireless_mesh_header.patch b/target/linux/generic/patches-3.7/651-wireless_mesh_header.patch
index ff3f0979f0..c21b007777 100644
--- a/target/linux/generic/patches-3.7/651-wireless_mesh_header.patch
+++ b/target/linux/generic/patches-3.7/651-wireless_mesh_header.patch
@@ -1,6 +1,6 @@
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -134,7 +134,7 @@ static inline bool dev_xmit_complete(int
+@@ -137,7 +137,7 @@ static inline bool dev_xmit_complete(int
*/
#if defined(CONFIG_WLAN) || IS_ENABLED(CONFIG_AX25)
diff --git a/target/linux/generic/patches-3.7/721-phy_packets.patch b/target/linux/generic/patches-3.7/721-phy_packets.patch
index 8dda0934b5..b8c15fcc6c 100644
--- a/target/linux/generic/patches-3.7/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.7/721-phy_packets.patch
@@ -1,6 +1,6 @@
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
-@@ -1074,6 +1074,11 @@ struct net_device {
+@@ -1077,6 +1077,11 @@ struct net_device {
const struct net_device_ops *netdev_ops;
const struct ethtool_ops *ethtool_ops;
@@ -12,7 +12,7 @@
/* Hardware header description */
const struct header_ops *header_ops;
-@@ -1130,6 +1135,9 @@ struct net_device {
+@@ -1133,6 +1138,9 @@ struct net_device {
void *ax25_ptr; /* AX.25 specific data */
struct wireless_dev *ieee80211_ptr; /* IEEE 802.11 specific data,
assign before registering */
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 650b90f702..c9bc96769f 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index efa17d986f..21caadce4a 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
DEVICE_TYPE:=developerboard
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index d7023cb6fc..399b05ea9e 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=squashfs targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index a7d4330c65..c84c0e2911 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
FEATURES:=spe_fpu ramdisk
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index b7dac46a3c..aa518a91d9 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 3cd2e2ae62..4d525e56af 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 80719258b3..a81610af67 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index c1672c29aa..b6fc34c411 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci targz broken
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index 29787294ea..901eb92a85 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
CS5535_MASK:=0x0b000042
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
index d1f73070fd..84621feba1 100644
--- a/target/linux/x86/geos/target.mk
+++ b/target/linux/x86/geos/target.mk
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
kmod-cpu-msr \
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
CS5535_MASK:=0x0E000048
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \