summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-25 21:45:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-25 21:45:51 +0000
commit11e1304ca0d2be464d881fca375f22deafd52536 (patch)
treef4eba264bb0dc752b046c6d0f2ed54836fac2ac0
parent5f2d2695d9a0090ddede54a61dde715b536fb4e7 (diff)
downloadmaster-31e0f0ae-11e1304ca0d2be464d881fca375f22deafd52536.tar.gz
master-31e0f0ae-11e1304ca0d2be464d881fca375f22deafd52536.tar.bz2
master-31e0f0ae-11e1304ca0d2be464d881fca375f22deafd52536.zip
globally define IPv6 support or not in OpenWrt, just like for largefiles, ipv6 disabled by default (#4857)
SVN-Revision: 16983
-rw-r--r--Config.in7
-rw-r--r--include/package-defaults.mk4
-rw-r--r--rules.mk14
3 files changed, 21 insertions, 4 deletions
diff --git a/Config.in b/Config.in
index d7ce63e462..18aafda3a7 100644
--- a/Config.in
+++ b/Config.in
@@ -142,6 +142,13 @@ config DEBUG_DIR
This will install all compiled package binaries into build_dir/target-*/debug-*/,
useful for cross-debugging via gdb/gdbserver
+config IPV6
+ bool
+ prompt "Enable IPv6 support in packages"
+ default n
+ help
+ Enable IPV6 support in packages (passes --enable-ipv6 to configure scripts).
+
comment "Kernel build options"
config KERNEL_KALLSYMS
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 753c10227e..3cba736f0f 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -60,7 +60,9 @@ CONFIGURE_ARGS = \
--localstatedir=/var \
--mandir=$(CONFIGURE_PREFIX)/man \
--infodir=$(CONFIGURE_PREFIX)/info \
- $(DISABLE_NLS)
+ $(DISABLE_NLS) \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_IPV6)
CONFIGURE_VARS = \
$(TARGET_CONFIGURE_OPTS) \
diff --git a/rules.mk b/rules.mk
index 05609b9ac0..3f39eefd7b 100644
--- a/rules.mk
+++ b/rules.mk
@@ -153,13 +153,21 @@ else
endif
ifeq ($(CONFIG_ENABLE_LOCALE),true)
- DISABLE_NLS:=
+ DISABLE_NLS:=--enable-nls
else
DISABLE_NLS:=--disable-nls
endif
-ifneq ($(CONFIG_LARGEFILE),y)
- DISABLE_LARGEFILE= --disable-largefile
+ifeq ($(CONFIG_IPV6),y)
+ DISABLE_IPV6:=--enable-ipv6
+else
+ DISABLE_IPV6:=--disable-ipv6
+endif
+
+ifeq ($(CONFIG_LARGEFILE),y)
+ DISABLE_LARGEFILE:=
+else
+ DISABLE_LARGEFILE:=--disable-largefile
endif
ifeq ($(CONFIG_TAR_VERBOSITY),y)