summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-26 09:49:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-26 09:49:32 +0000
commit1185e645a773c86aa88cf04d0e2911dc62eb43f5 (patch)
treede9f23207ffb40700b280dfd3ddd03ff9d2ca36b
parentb5bfb3534b693f7781978b369d4f1bb2995bfcd4 (diff)
downloadmaster-31e0f0ae-1185e645a773c86aa88cf04d0e2911dc62eb43f5.tar.gz
master-31e0f0ae-1185e645a773c86aa88cf04d0e2911dc62eb43f5.tar.bz2
master-31e0f0ae-1185e645a773c86aa88cf04d0e2911dc62eb43f5.zip
kernel: disable MIPS VDSO by default until the cache issues have been resolved
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48802
-rw-r--r--target/linux/generic/patches-4.4/206-mips-disable-vdso.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
new file mode 100644
index 0000000000..9b1346db81
--- /dev/null
+++ b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
@@ -0,0 +1,21 @@
+Disable MIPS VDSO until the cache issues have been sorted out.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
+ # the comments on that file.
+ #
+ ifndef CONFIG_CPU_MIPSR6
+- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+- $(warning MIPS VDSO requires binutils >= 2.25)
++# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
++# $(warning MIPS VDSO requires binutils >= 2.25)
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
+- endif
++# endif
+ endif
+
+ # VDSO linker flags.