summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-01-22 08:12:20 +0000
committerNicolas Thill <nico@openwrt.org>2010-01-22 08:12:20 +0000
commit0f3c406bdb09b6fe95487e8924bb26a0358440de (patch)
tree68a16c147e72fe57d0d22c8f9259a710e9ccbd4d
parent946291c8d56c01d634c0f032a8fc52b2bf8febf5 (diff)
downloadmaster-31e0f0ae-0f3c406bdb09b6fe95487e8924bb26a0358440de.tar.gz
master-31e0f0ae-0f3c406bdb09b6fe95487e8924bb26a0358440de.tar.bz2
master-31e0f0ae-0f3c406bdb09b6fe95487e8924bb26a0358440de.zip
add a config item to specify arguments to strip
SVN-Revision: 19270
-rw-r--r--Config.in9
-rw-r--r--rules.mk2
2 files changed, 10 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 1f689c0664..c798510f0c 100644
--- a/Config.in
+++ b/Config.in
@@ -173,6 +173,15 @@ choice
endchoice
+config STRIP_ARGS
+ string
+ prompt "Strip arguments"
+ depends USE_STRIP
+ default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG
+ default "--strip-all"
+ help
+ Specifies arguments passed to the strip command when stripping binaries
+
config USE_MKLIBS
bool "Strip unnecessary functions from libraries"
help
diff --git a/rules.mk b/rules.mk
index 31c8854e9d..3473b212de 100644
--- a/rules.mk
+++ b/rules.mk
@@ -174,7 +174,7 @@ ifneq ($(CONFIG_NO_STRIP),)
STRIP:=:
else
ifneq ($(CONFIG_USE_STRIP),)
- STRIP:=$(TARGET_CROSS)strip
+ STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS))
else
ifneq ($(CONFIG_USE_SSTRIP),)
STRIP:=$(STAGING_DIR_HOST)/bin/sstrip