summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:01 +0000
commit0c0b87293e46fd483a823f4b40244db8e8d3dd11 (patch)
treea72cc4274c2d0cb95f369f26e55712e9302466b8
parent2995030b470824567895e46d6c37cad6f20cf4a1 (diff)
downloadmaster-31e0f0ae-0c0b87293e46fd483a823f4b40244db8e8d3dd11.tar.gz
master-31e0f0ae-0c0b87293e46fd483a823f4b40244db8e8d3dd11.tar.bz2
master-31e0f0ae-0c0b87293e46fd483a823f4b40244db8e8d3dd11.zip
ar71xx: image: use a single firmware partition on Compex devices
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39389
-rw-r--r--target/linux/ar71xx/image/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 7531340206..5fe8ae4cbe 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -453,10 +453,16 @@ Image/Build/MyLoader/buildkernel=$(call PatchKernelLzma,$(2),$(3))
Image/Build/MyLoader/initramfs=$(call PatchKernel/initramfs,$(2),$(3))
define Image/Build/MyLoader
- -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \
- -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR_TMP)/vmlinux-$(2).bin.lzma \
- -p0x110000:0:::rootfs:$(KDIR)/root.$(1) \
- $(call imgname,$(1),$(2))-$(5)-factory.img
+ $(eval fwsize=$(shell echo $$(($(4)-0x30000-4*64*1024))))
+ $(eval fwimage=$(KDIR_TMP)/$(2)-$(5)-firmware.bin)
+ $(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).bin.lzma,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
+ if [ -e "$(fwimage)" ]; then \
+ cp $(fwimage) $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
+ $(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
+ -p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
+ $(call imgname,$(1),$(2))-$(5)-factory.img; \
+ true; \
+ fi
endef