summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:30:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-28 00:30:09 +0000
commit090680f083380a3ff7aa32991399db27d0393b81 (patch)
treebb4027c10ad78d6cc21d19c9dbb3e679202785d7
parent278589f5d70dbe790d31cb5015d3723daa739941 (diff)
downloadmaster-31e0f0ae-090680f083380a3ff7aa32991399db27d0393b81.tar.gz
master-31e0f0ae-090680f083380a3ff7aa32991399db27d0393b81.tar.bz2
master-31e0f0ae-090680f083380a3ff7aa32991399db27d0393b81.zip
pptp: support interface sections without ifname by implementing scan_pptp()
SVN-Revision: 21590
-rw-r--r--package/pptp/Makefile2
-rw-r--r--package/pptp/files/pptp.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index 018e9b570e..a55309bf51 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pptp
PKG_VERSION:=1.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/pptpclient
diff --git a/package/pptp/files/pptp.sh b/package/pptp/files/pptp.sh
index c95895d9fa..436bee3c87 100644
--- a/package/pptp/files/pptp.sh
+++ b/package/pptp/files/pptp.sh
@@ -2,6 +2,10 @@ find_gw() {
route -n | awk '$1 == "0.0.0.0" { print $2; exit }'
}
+scan_pptp() {
+ config_set "$1" device "pptp-$1"
+}
+
stop_interface_pptp() {
stop_interface_ppp "$1"
}