summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-02 12:01:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-02 12:01:08 +0000
commit0670771013fc8abcc45ad95b32880bfeebcdb246 (patch)
tree4fcd4207d5559702d836af158859360bcbfd75f8
parent0e4c9de00e55e205165e38b3605f3916366d58a6 (diff)
downloadmaster-31e0f0ae-0670771013fc8abcc45ad95b32880bfeebcdb246.tar.gz
master-31e0f0ae-0670771013fc8abcc45ad95b32880bfeebcdb246.tar.bz2
master-31e0f0ae-0670771013fc8abcc45ad95b32880bfeebcdb246.zip
hostapd: use -ffunction-sections, -fdata-sections and --gc-sections, reduces binary size a bit
SVN-Revision: 25821
-rw-r--r--package/hostapd/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3b4978fc86..83622b41ba 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -225,6 +225,9 @@ TARGET_CPPFLAGS := \
-DCONFIG_LIBNL20 \
-D_GNU_SOURCE
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny
endif