summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-08 10:04:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-08 10:04:39 +0000
commit0485747912e017b02291895cee04c5cce47150a4 (patch)
tree239eef15066b5d5cad77d8d0c7f9f60317a639dc
parent76e8aae3abb7a12b0ec8f629118a06eae07e2c54 (diff)
downloadmaster-31e0f0ae-0485747912e017b02291895cee04c5cce47150a4.tar.gz
master-31e0f0ae-0485747912e017b02291895cee04c5cce47150a4.tar.bz2
master-31e0f0ae-0485747912e017b02291895cee04c5cce47150a4.zip
kernel: fix x86 objdump invocation on 3.14 and 3.18
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43557
-rw-r--r--target/linux/generic/patches-3.14/270-x86_objdump_command.patch16
-rw-r--r--target/linux/generic/patches-3.18/270-x86_objdump_command.patch11
2 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/270-x86_objdump_command.patch b/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
new file mode 100644
index 0000000000..15062691a8
--- /dev/null
+++ b/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
@@ -0,0 +1,16 @@
+Use the cross toolchain objdump command instead of assuming that the host
+toolchain has it.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
+ suffix-$(CONFIG_KERNEL_LZO) := lzo
+ suffix-$(CONFIG_KERNEL_LZ4) := lz4
+
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+ perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+ cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
diff --git a/target/linux/generic/patches-3.18/270-x86_objdump_command.patch b/target/linux/generic/patches-3.18/270-x86_objdump_command.patch
new file mode 100644
index 0000000000..7d4170ebee
--- /dev/null
+++ b/target/linux/generic/patches-3.18/270-x86_objdump_command.patch
@@ -0,0 +1,11 @@
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -76,7 +76,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
+ suffix-$(CONFIG_KERNEL_LZO) := lzo
+ suffix-$(CONFIG_KERNEL_LZ4) := lz4
+
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+ perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+ cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )