summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-22 12:51:04 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-22 12:51:04 +0000
commit02198322b93665d332464e942ff848e55cfb0c21 (patch)
tree6b37a91f6d054547070b4c1faab4508401c32ea8
parent2911b5aa11ed579e74d0f7309ed8935d3ecea62d (diff)
downloadmaster-31e0f0ae-02198322b93665d332464e942ff848e55cfb0c21.tar.gz
master-31e0f0ae-02198322b93665d332464e942ff848e55cfb0c21.tar.bz2
master-31e0f0ae-02198322b93665d332464e942ff848e55cfb0c21.zip
kernel: update 4.0 to 4.0.9
Changelog: * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.9 Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46440
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-4.0/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch2
-rw-r--r--target/linux/generic/patches-4.0/921-use_preinit_as_init.patch2
4 files changed, 5 insertions, 5 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 0a4243e8d0..e03590f03a 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,11 +3,11 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .19
-LINUX_VERSION-4.0 = .8
+LINUX_VERSION-4.0 = .9
LINUX_VERSION-4.1 = .3
LINUX_KERNEL_MD5SUM-3.18.19 = a143f9421bd8413752609d0d771c2955
-LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
+LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
LINUX_KERNEL_MD5SUM-4.1.3 = 96c2c77b1c54ba01cfd8fc2d13fbf828
ifdef KERNEL_PATCHVER
diff --git a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch b/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
index 1e80aa2f2c..dd42895108 100644
--- a/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-4.0/259-regmap_dynamic.patch
@@ -75,7 +75,7 @@
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/of.h>
-@@ -2632,3 +2633,5 @@ static int __init regmap_initcall(void)
+@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
diff --git a/target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch b/target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch
index eee15517e0..8f72637eec 100644
--- a/target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch
+++ b/target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch
@@ -1,6 +1,6 @@
--- a/drivers/pci/Kconfig
+++ b/drivers/pci/Kconfig
-@@ -64,6 +64,12 @@ config XEN_PCIDEV_FRONTEND
+@@ -68,6 +68,12 @@ config XEN_PCIDEV_FRONTEND
The PCI device frontend driver allows the kernel to import arbitrary
PCI devices from a PCI backend to support PCI driver domains.
diff --git a/target/linux/generic/patches-4.0/921-use_preinit_as_init.patch b/target/linux/generic/patches-4.0/921-use_preinit_as_init.patch
index 16448a4162..d0aa29f145 100644
--- a/target/linux/generic/patches-4.0/921-use_preinit_as_init.patch
+++ b/target/linux/generic/patches-4.0/921-use_preinit_as_init.patch
@@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
-@@ -956,7 +956,8 @@ static int __ref kernel_init(void *unuse
+@@ -957,7 +957,8 @@ static int __ref kernel_init(void *unuse
panic("Requested init %s failed (error %d).",
execute_command, ret);
}