aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt')
-rw-r--r--3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt b/3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt
new file mode 100644
index 00000000..9bffcd7f
--- /dev/null
+++ b/3rdparty/QtPropertyBrowser/examples/canvas_typed/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Tell CMake to run moc when necessary:
+set(CMAKE_AUTOMOC ON)
+
+# As moc files are generated in the binary dir, tell CMake
+# to always look for includes there:
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+SET(example_name canvas_typed)
+
+SET(KIT_SRCS
+ main.cpp
+ mainwindow.cpp
+ mainwindow.h
+ qtcanvas.cpp
+ qtcanvas.h
+ )
+
+ADD_EXECUTABLE(${example_name} ${KIT_SRCS})
+TARGET_LINK_LIBRARIES(${example_name} ${PROJECT_NAME})