summaryrefslogtreecommitdiffstats
path: root/src/python/setup.py
diff options
context:
space:
mode:
authorBaruch Sterin <baruchs@gmail.com>2011-01-13 22:11:37 +0200
committerBaruch Sterin <baruchs@gmail.com>2011-01-13 22:11:37 +0200
commitc85a763444f696e0125445b5adc675020d736c5d (patch)
tree03d28593a06c5549949e35106939589ef05cb853 /src/python/setup.py
parentf4066b5be3b5473f5c64ab71d1983df6ca7aec76 (diff)
downloadabc-c85a763444f696e0125445b5adc675020d736c5d.tar.gz
abc-c85a763444f696e0125445b5adc675020d736c5d.tar.bz2
abc-c85a763444f696e0125445b5adc675020d736c5d.zip
pyabc: make the SIGINT signal handler clean up by sending SIGINT to child processes registered by the python code. Also provide functions to block SIGINT and unblock it, to allow for critical sections where signals are blocked
Diffstat (limited to 'src/python/setup.py')
-rw-r--r--src/python/setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/python/setup.py b/src/python/setup.py
index abc07afa..af2f5547 100644
--- a/src/python/setup.py
+++ b/src/python/setup.py
@@ -6,6 +6,7 @@ from distutils import util
include_dirs = [
'../aig/hop',
+ '../aig/gia',
'../base/abc',
'../base/cmd',
'../base/io',
@@ -18,6 +19,7 @@ include_dirs = [
'../misc/st',
'../misc/util',
'../misc/vec',
+ '../misc/hash',
]
define_macros = []