summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBaruch Sterin <baruchs@gmail.com>2015-11-12 11:43:59 -0800
committerBaruch Sterin <baruchs@gmail.com>2015-11-12 11:43:59 -0800
commit3237ebafaa36ccc114a4274ff9ca9f5dfe61821b (patch)
tree5f423558aa43814c0e992b9dbd5c884a7dd54367 /CMakeLists.txt
parentf7c969ca66649627281510b8c63d867288faafd7 (diff)
downloadabc-3237ebafaa36ccc114a4274ff9ca9f5dfe61821b.tar.gz
abc-3237ebafaa36ccc114a4274ff9ca9f5dfe61821b.tar.bz2
abc-3237ebafaa36ccc114a4274ff9ca9f5dfe61821b.zip
CMake, Makefile: pass the location of arch_flags to the makefile, this way the cmake build does not write to the soruce directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04b882d0..977f0938 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,7 @@ execute_process(
make
${ABC_READLINE_FLAGS}
${ABC_USE_NAMESPACE}
+ ARCHFLAGS_EXE=${CMAKE_CURRENT_BINARY_DIR}/abc_arch_flags_program.exe
ABC_MAKE_NO_DEPS=1
CC=${CMAKE_C_COMPILER}
CXX=${CMAKE_CXX_COMPILER}