aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 16 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 7ebeb208..180058a2 100644
--- a/setup.py
+++ b/setup.py
@@ -62,25 +62,27 @@ setup(
# It is not considered best practice to use install_requires to pin dependencies to specific versions.
install_requires=[
"blinker>=1.4, <1.5",
- "brotlipy>=0.7.0,<0.8",
- "certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
+ "Brotli>=1.0,<1.1",
+ "certifi>=2019.9.11", # no semver here - this should always be on the last release!
"click>=6.2, <7",
- "cryptography>=2.1.4,<2.4",
+ "cryptography>=2.1.4,<2.5",
"h2>=3.0.1,<4",
"hyperframe>=5.1.0,<6",
"kaitaistruct>=0.7,<0.9",
- "ldap3>=2.5,<2.6",
+ "ldap3>=2.6.1,<2.7",
"passlib>=1.6.5, <1.8",
- "protobuf>=3.6.0, <3.7",
+ "protobuf>=3.6.0, <3.10",
"pyasn1>=0.3.1,<0.5",
- "pyOpenSSL>=17.5,<18.1",
- "pyparsing>=2.1.3, <2.3",
- "pyperclip>=1.6.0, <1.7",
- "ruamel.yaml>=0.13.2, <0.15.55",
+ "pyOpenSSL>=19.0.0,<20",
+ "pyparsing>=2.4.2,<2.5",
+ "pyperclip>=1.6.0,<1.8",
+ "ruamel.yaml>=0.15,<0.16",
"sortedcontainers>=1.5.4,<2.1",
"tornado>=4.3,<5.2",
"urwid>=2.0.1,<2.1",
- "wsproto>=0.11.0,<0.12.0",
+ "wsproto>=0.14.0,<0.15.0",
+ "publicsuffix2~=2.20",
+ "zstandard>=0.11.0,<0.13.0",
],
extras_require={
':sys_platform == "win32"': [
@@ -88,8 +90,8 @@ setup(
],
'dev': [
"asynctest>=0.12.0",
- "flake8>=3.5, <3.6",
- "Flask>=1.0,<1.1",
+ "flake8>=3.5,<=3.7.8",
+ "Flask>=1.0,<1.2",
"mypy>=0.590,<0.591",
"parver>=0.1,<2.0",
"pytest-asyncio>=0.8",
@@ -97,9 +99,9 @@ setup(
"pytest-faulthandler>=1.3.1,<2",
"pytest-timeout>=1.2.1,<2",
"pytest-xdist>=1.22,<2",
- "pytest>=3.3,<4",
+ "pytest>=4.0,<5",
"requests>=2.9.1, <3",
- "tox>=3.0,<3.2",
+ "tox>=3.5,<3.6",
"rstcheck>=2.2, <4.0",
],
'examples': [