aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 8 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 9eb5858e..d6016746 100644
--- a/setup.py
+++ b/setup.py
@@ -29,22 +29,21 @@ setup(
classifiers=[
"License :: OSI Approved :: MIT License",
"Development Status :: 5 - Production/Stable",
- "Environment :: Console",
"Environment :: Console :: Curses",
- "Operating System :: MacOS :: MacOS X",
+ "Operating System :: MacOS",
"Operating System :: POSIX",
"Operating System :: Microsoft :: Windows",
- "Programming Language :: Python",
- "Programming Language :: Python :: 3",
"Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
"Programming Language :: Python :: Implementation :: CPython",
"Topic :: Security",
- "Topic :: Internet",
"Topic :: Internet :: WWW/HTTP",
"Topic :: Internet :: Proxy Servers",
- "Topic :: Software Development :: Testing"
+ "Topic :: System :: Networking :: Monitoring",
+ "Topic :: Software Development :: Testing",
+ "Typing :: Typed",
],
packages=find_packages(include=[
"mitmproxy", "mitmproxy.*",
@@ -69,7 +68,7 @@ setup(
"click>=7.0,<8",
"cryptography>=2.9,<3.0",
"flask>=1.1.1,<1.2",
- "h2>=3.0.1,<4",
+ "h2>=3.2.0,<4",
"hyperframe>=5.1.0,<6",
"kaitaistruct>=0.7,<0.9",
"ldap3>=2.6.1,<2.7",
@@ -82,7 +81,7 @@ setup(
"ruamel.yaml>=0.16,<0.17",
"sortedcontainers>=2.1.0,<2.2",
"tornado>=4.3,<7",
- "urwid>=2.0.1,<2.1",
+ "urwid>=2.1.0,<2.2",
"wsproto>=0.14.0,<0.15.0",
"publicsuffix2>=2.20190812,<3",
"zstandard>=0.11.0,<0.13.0",
@@ -95,7 +94,7 @@ setup(
"asynctest>=0.12.0",
"flake8>=3.7.8,<3.8",
"Flask>=1.0,<1.2",
- "mypy>=0.740,<0.741",
+ "mypy>=0.740,<0.771",
"parver>=0.1,<2.0",
"pytest-asyncio>=0.10.0,<0.11",
"pytest-cov>=2.7.1,<3",