aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 598643b6..2f32c766 100644
--- a/setup.py
+++ b/setup.py
@@ -14,11 +14,21 @@ from distutils.command.build import build
import pkg_resources
+import setuptools
from setuptools import find_packages, setup
from setuptools.command.install import install
from setuptools.command.test import test
+if (
+ pkg_resources.parse_version(setuptools.__version__) <
+ pkg_resources.parse_version("18.5")
+):
+ raise RuntimeError(
+ "cryptography requires setuptools 18.5 or newer, please upgrade to a "
+ "newer version of setuptools"
+ )
+
base_dir = os.path.dirname(__file__)
src_dir = os.path.join(base_dir, "src")