aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 00922222..cb2cbaed 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -106,8 +106,8 @@ target_link_libraries(gtest_main gtest)
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gtest INTERFACE "${gtest_SOURCE_DIR}/include")
- target_include_directories(gtest_main INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest_main SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
endif()
########################################################################