aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F0xx/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/STM32/STM32F0xx/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32F0xx/platform.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/os/hal/ports/STM32/STM32F0xx/platform.mk b/os/hal/ports/STM32/STM32F0xx/platform.mk
index a1177882a..b8975be7e 100644
--- a/os/hal/ports/STM32/STM32F0xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F0xx/platform.mk
@@ -11,11 +11,15 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
ifeq ($(USE_SMART_BUILD),yes)
# Configuration files directory
-ifeq ($(CONFDIR),)
- CONFDIR = .
+ifeq ($(HALCONFDIR),)
+ ifeq ($(CONFDIR),)
+ HALCONFDIR = .
+ else
+ HALCONFDIR := $(CONFDIR)
+ endif
endif
-HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
+HALCONF := $(strip $(shell cat $(HALCONFDIR)/halconf.h | egrep -e "\#define"))
else
endif