aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/LPC/LPC214x/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/LPC/LPC214x/platform.mk')
-rw-r--r--os/hal/ports/LPC/LPC214x/platform.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/os/hal/ports/LPC/LPC214x/platform.mk b/os/hal/ports/LPC/LPC214x/platform.mk
new file mode 100644
index 000000000..bd6b2761e
--- /dev/null
+++ b/os/hal/ports/LPC/LPC214x/platform.mk
@@ -0,0 +1,9 @@
+# List of all the LPC214x platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/LPC/LPC214x/hal_lld.c \
+ ${CHIBIOS}/os/hal/ports/LPC/LPC214x/pal_lld.c \
+ ${CHIBIOS}/os/hal/ports/LPC/LPC214x/serial_lld.c \
+ ${CHIBIOS}/os/hal/ports/LPC/LPC214x/spi_lld.c \
+ ${CHIBIOS}/os/hal/ports/LPC/LPC214x/vic.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/LPC/LPC214x