aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/LLD/I2C
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/TIVA/LLD/I2C')
-rw-r--r--os/hal/ports/TIVA/LLD/I2C/driver.mk9
-rw-r--r--os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c4
-rw-r--r--os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.h4
3 files changed, 13 insertions, 4 deletions
diff --git a/os/hal/ports/TIVA/LLD/I2C/driver.mk b/os/hal/ports/TIVA/LLD/I2C/driver.mk
new file mode 100644
index 0000000..d327a19
--- /dev/null
+++ b/os/hal/ports/TIVA/LLD/I2C/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_I2C TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/I2C
diff --git a/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c b/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c
index cf70dca..fd7395f 100644
--- a/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c
+++ b/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.c
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -15,7 +15,7 @@
*/
/**
- * @file TIVA/LLD/i2c_lld.c
+ * @file I2C/hal_i2c_lld.c
* @brief TM4C123x/TM4C129x I2C subsystem low level driver source.
*
* @addtogroup I2C
diff --git a/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.h b/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.h
index 4eabda8..66669f1 100644
--- a/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.h
+++ b/os/hal/ports/TIVA/LLD/I2C/hal_i2c_lld.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -15,7 +15,7 @@
*/
/**
- * @file TIVA/LLD/i2c_lld.h
+ * @file I2C/hal_i2c_lld.h
* @brief TM4C123x/TM4C129x I2C subsystem low level driver header.
*
* @addtogroup I2C